Tuesday, May 6, 2014

New S150 KoTiX  2.1 Rom available!!

I've uploaded the new version of my Aroma 4.03 rom v2.1, download link is at the end of the post.

First I'd like to thanks the russian developer Dimadina for his 160 DPI mod, the UI looks a lot of better now, the third party apps and the whole UI is not zoomed anymore and it's much better to use. So all credits for this mod goes to him :good:

From Dimadina  rom I also decide to copy the same MCU file becaue the V003 included in the 28/03 original winca fw is not stable and was causing me problems at boot/shutdown of the unit, like taking around 10 seconds to light up the power button before the logo.

So this is the changelog:

04.05.2014 - Added Custom Bootanimation option
30.05.2014 - Fixed Viper Lib installation
           - Changed Aroma resolution to lower dpi
           - Fixed Aroma progress bar
           - Added option to use 160 dpi interface

I increased the Aroma resolution, so we have more room for cheboxes and the progress bar is kind of working now (need more fixes  but it's ok)
Viper4Android now install without problems, you don't have to install the drivers, just enable it for the speakers.
If you select 160 DPI mod you can still choose my modded version of the radio and bluetooth apk.
I added the option to install a bootanimation in "data/local" just put the bootanimation.zip in the "bootanimation" folder, best if you use a "...x480" resolution as the screen size is 800x480, just don't use a 480x800 that is vertical mode.

If this rom don't have problems, I will stop for a while modding the 4.03 rom and I'll start porting the aroma installer, the modded radio and other mods to the 2.34 fw. With the aroma will be easyer to move to 4.03 and go back to 2.34 without flashing MCU.

Enjoy ;)



S150 4.03 Aroma-Root-160DPI_v2.1


(As always the firmware is made for the C001/I001 model, if you have different unit, use it at your own risk and be sure you have the original firmware for backup and you know what you are doing, specially regarding the risks of flashing MCU.)

---------------------------------------------------------------------------------------------------------------


I spend a lot of time developing and helping people here and on the forums, so before hammering me with emails and messages and if you like my work and you think i should keep doing it,
 please consider donating.

40 comments:

  1. Installed on my S100 unit and working fine!

    ReplyDelete
  2. Hi,

    Nice ROM, it works just fine. Except for one thing.

    If you check for OpenGL ES 2 support from java code like this:

    ActivityManager am = (ActivityManager)getSystemService(Context.ACTIVITY_SERVICE);
    ConfigurationInfo info = am.getDeviceConfigurationInfo();

    info.reqGlEsVersion is going to be zero, which means there is no OpenGL ES 2 support from java. However, when installing a pure C++ OpenGL ES 2 program, they just work fine.

    So basically C++ code can use OpenGL ES 2, but Java code not. This means all the OpenGL ES 2 based programs are missing from the GPlay, and they fail to run when installed manually.

    Check this program from the GPlay to check it out easily: https://play.google.com/store/apps/details?id=nl.svdree.glesinfo

    It reports no available OpenGL ES 2 profiles. However if you install any GLES2 samples from the PowerVR SDK, which are C++ based, they are working fine.

    Can you look at this issue?

    Thank you

    László

    ReplyDelete
    Replies
    1. I don't have any source code of the rom so I just modify what I can... if there is a smali,xml or any script changes that i can do I'll surely do it but If it's something harder that need source code I'll be out of the game.
      Tnx anyway for reporting it.
      Cheers :)

      Delete
  3. ya esta instalada en mi s100 pero no me gusta el dpi160 debe pulirse mejor este aspecto, todo lo demas perfecto

    ReplyDelete
  4. Os dejo un pequeño video en YouTube
    https://m.youtube.com/watch?v=4f-gJ4Qoi4c

    ReplyDelete
  5. how do i install supersu?
    is it already rooted?

    ReplyDelete
  6. I installed the firmware without writing to flash and mcu.

    It worked like a charm.

    Thank you,

    ReplyDelete
  7. Hello.
    I commend the work of KoTiX, very good, I thought you could not change the interface of the s100

    I have a s100 I purchased to install in my car, WinCE. s100-s100-uni20130724 v1.4.7.0, can I install Android to the team?, can help me install it without messing up my computer, I also like to make a backup before attempting to install the Android

    Greetings.

    ReplyDelete
    Replies
    1. you need your original firmware first or at least you should know your model number.
      Once you have them, follow the guide here:
      http://kotixworld.blogspot.it/2014/01/s100-to-s150-conversion-convert-wince.html

      Delete
  8. Good Work.

    However, I have two questions:
    1) in version 2.3.4 had in the area of ​​notifications, such as finalize an application, such as turning off the radio or video (there was a close button, which finished off the application). I did not find how to do this in a simple way in this application. Can guide me?
    2) as an application for GPS, I use Waze, in my tests, after install, it does not end the configuration process. When I accepted the conditions of use he interrupts himself and closes. Did you have something about it?

    ReplyDelete
    Replies
    1. 1) unfortunately there is not that button in 4.03 fw
      2)I just installed waze in my new fresh rom and it works:
      https://www.dropbox.com/s/kkczgv1mjg9atx2/S150%204.03%20KoTiX_v2.2.rar
      This rom is based on latest 30/04 firmware from roadnav/winca

      Delete
    2. Hi! I installed the 2.2 version of 4.03 fw, and the Waze still didn't work. It stops at the same point ever (config process - accepted the conditions).

      Delete
    3. Hello I have the same problem with waze on android 4.0.3

      Delete
    4. So I upgraded to V2.2 4:03, the problem with Waze continues, it aborts when I agree to the terms of use. Would anyone ever been that this problem could fix it?

      Delete
    5. Friends, I noticed that the XDA forum for Waze work correctly, it needs Google Play Service (see comment in http://forum.xda-developers.com/showthread.php?t=2503964&page=112), so I tried to install Play by Google and not installed. I conducted tests with all versions listed in http://www.xda-developers.com/android/apk-compendium-google-play-services-4-4-52-for-all-densities-and-the-rest-of-this-weeks-updates/, but none of them installed.
      KoTiX friend, you have Google Play Service installed? If so, this may be the impediment for me. What is and where do I get the APK Google Play Services compatible with S150?

      Delete
    6. OK i've reflashed my 2.2 ROM, connected to WiFi and installed waze from playstore. All went just fine.
      In my installer i choosed root,160dpi,radiomod,btmod and viper.
      If you guys have choosed the same options i only can think of a language problem (maybe?), i used english language. What did you use?

      Delete
    7. This comment has been removed by the author.

      Delete
    8. Reinstalled a custom full version. Waze works normally. Thanks

      Delete
    9. So what 's the difference between now and before in your setup?
      What did it make working?

      Delete
    10. The first time I ran the installation using the FULL option, and Waze did not work. The second time I ran the installation using the CUSTOM option, and then he usually worked.

      Delete
  9. Hello KoTiX! I have a S150 I109, when trying to install an upgrade turned out well and no longer works well, has many faults. Perform an update with files sent by the seller of radio installed in the slot but does not update the GPS does not work anything. You can help me to update I have no problem in making payment for the repair thanks

    ReplyDelete
  10. This comment has been removed by the author.

    ReplyDelete
  11. So I think I have a problem, ops!
    Because of Wase not be operating in V4, performed a downgrade described in http://forum.xda-developers.com/showthread.php?t=2503964, and it worked.
    But now I can no longer perform the upgrade, prepare the sdcard, but when I do the process, he does not start the upgrade, stays with black screen, so I cut the power and when I turn it is version 2.3.4.
    I do not know what to do.

    ReplyDelete
    Replies
    1. Are you sure you are fusing the correct bootloader for 4.03 fw?
      https://www.dropbox.com/s/fxwpix9haph0xm0/u-boot_udsd.bin
      Be sure also you make a double copy of all files and folders in the root of SD and in the "winca" folder as described in the s100 to s150 conversion guide:
      http://kotixworld.blogspot.it/2014/01/s100-to-s150-conversion-convert-wince.html

      Delete
  12. do you think i can upgrade this unit (http://www.aliexpress.com/item/Android-OS-3G-WiFi-Car-DVD-GPS-Sat-Navi-Headunit-For-Mitsubishi-ASX-RVR-2010-2011/1507527666.html) to 4.03 ?????

    ReplyDelete
    Replies
    1. The unit is i026:http://www.carnaviplayer.com/android-os-navigation-radio-player-for-mitsubishi-asx-rvr-p-1016
      You can upgrade but i don't know if canbus will work on 4.03

      Delete
    2. Hi, do you have the original firmware ?

      Delete
  13. The unit is i026:http://www.carnaviplayer.com/android-os-navigation-radio-player-for-mitsubishi-asx-rvr-p-1016
    You can upgrade but i don't know if canbus will work on 4.03

    ReplyDelete
  14. Una duda. Puedo cojer el mcu y el flash. Y el. Config de la rom original 2.3.6 para el megane 3,
    Que debería notar en el funcionamiento del aparato?

    ReplyDelete
  15. Music player does not show the album art in the 4.0.3 version. Any ideas how to fix.

    ReplyDelete
    Replies
    1. No idea, Just try a newer firmware

      Delete
  16. Hola kotix. La velocidad del gps se pone a cero y vuelve a marcar la. Velocidad de navegación. Y así un buen rato. Y Luego va bien. Y al Cabo de unos minutos vuelve a hacerlos durante unos minutos más. No es gps ya que no pierde los satélites.
    Alguna idea de lo puede ser?

    ReplyDelete
  17. No lo se Eric, yo no uso mucho los navegadores.

    ReplyDelete