Monday, October 27, 2014

I am back to Wince S100! NEW SKINPACK!! Radio stations stored by RDS name!!

Yes, you read it right! After one year of android fun I decided to switch back to wince and probably I'll on it. Here are my reasons for that:

1. Running android 4.03 some people, including me, are experiencing hardware faults caused by the overheating of the cpu that loose contact from the mainboard.
One of the simptoms of this is the loss of audio from the android software like audio or video player, navi sw, etc.. while the audio from radio, tv and dvd is still there.
Sometimes is enought to restart the unit and the audio come back but in other critical cases it is necessary to apply an hardware fix ,tipically a reflow. On xda forum some people have already done it successfully and their unit went back working normally but it's hard to tell how long it will last.
I'm experiencing this issue too  and i don't want to risk to replace another cpu board.
2. Wince is faster in booting, recognizing usb sticks and mostly all other things but more than anything else... it never crash!
3. In newest wince firmware Winca have added the function to store the radio stations by RDS name instead of frequency numbers.
4. A russian guy have reworked the audio player "Nitrogen" making it perfectly integrated with the unit where now even the steering wheel controls work.


5. All the android apps are nice but most of them are unusefull on a car unit, most are just phone centrated.


So summing all these points i decided to switch back to wince, I restarted working on my skins, adapting and fixing the Skinpack for the new firmwares:




and i also made a skin for Nitrogen that fit my skin4:


Here is the link to latest Skinpack:

S100 Skinpack 26.10.2014.rar

it include Nitrogen and its skin4, it can be installed as an extra app, as the default music player or even both.

Extract the skinpack on the root of SD card and put it in GPS slot, on the unit set Navi path to "\Skinmanager\Skinmanager.exe", press the Navi button

This is the Skinpack most recent changelog:

26.10.2014
- Fixed Nitrogen launch as extra app
- Moved audio player and nitrogen playlist button to match radio list position
- Better radio keyboard
- Some skinmanager fixes
- Added names to Skinmanager and Nitrogen icons in extra app
19.10.2014
- Updated Skin 2, 3 and 4 to new firmware version 1.6.9
- Updated Nitrogen to 14/10/2014 version with SWC and more integration into S100 platform
- Added Nitrogen Skin4

UPDATE: All the skinpack aren't free anymore, to download the skinpack you have togo to this post and buy it:

Once the payment is confirmed you will be redirected to the Skinpacks folder where you can find older versions, the curent one  and even the new ones when they will be available.

These are the packs included in the folder now:
- Skinpack 12.01.15 for fw 1.7.9
- Skinpack for fw 1.6.9
- SkinPack for fw 1.0.9.0 to 1.6.9
- SkinPack for fw up to 1.18.7

116 comments:

  1. Hi Kotix!
    Where can I download the last version of the WINCE? And this last version has portuguese language?
    Yours skins are installed together or after of upgrade the unit? And, the skins works with portuguese? If not, can i change the text?
    PS: Currently, I've the Android version on S100.
    Thanks.

    ReplyDelete
    Replies
    1. I will make a new post with detailed instructions to switch back to wince, for now here is the last wince Fw:
      https://www.dropbox.com/s/e3t8qm8g5oy988x/C149%201.6.9.18%20F00N%20S00E.rar?dl=0
      And here is wince-sdboot to go back to wince:
      https://www.dropbox.com/s/ncr3vioawoslmnx/SDBOOT_wince.zip?dl=0
      Instructions are inside the zip.
      This tool is to convert the Fw for your model:
      https://www.dropbox.com/s/ubp2gsnfxgrrhel/SetUpdateXML_EN_2.exe?dl=0
      Portugues should be there, skins work on any language. To install skins you use skinmanager after flash.

      Delete
    2. Will there be any problem if I install this version because my unit is model 239. Tks.

      Delete
    3. It depend if your unit use a standard mcu or a specific one for your unit.
      Will be better if you find an original wince fw for your unit, take the mcu.bin from there and replace it in the new fw.
      Otherwise take the risk and flash the mcu that come with this fw.

      Delete
    4. Hi,
      I used this firmware on my unit (239) and it worked.
      Only have a few observations:
      - My TV only works with the last channel tuned. I can't change channels. I believe that is the TV mode (DTV, Analog, etc). How can I change?
      - The RDS radio is shuffling the letters of the words, ie for the name of radios and other information.
      - For videos, there is a delay of about 3 to 4 seconds to start a video, either for the first time or to move from one to the other.
      - The date on the Radio is in american format (month, day, week). Is there possible to change?
      - About SDCARD, since I used it to install the firmware, I can't reuse it for the GPS? I formatted it and put iGO, but when I turn on the unit, the display goes blank. I have to turn on it without the SDCARD.
      - When I put PiP and with radio is working, the numbers of the radio station name is shuffled. If I undo and redo PiP, it back to normal.

      Tks

      Delete
  2. Hi KoTIX and thanks for your firmware!
    do you have a tuto to explain how to proceed to load your firmware?
    I've a Honda CRV and put your firmware on a SD card, plug it to the GPS slot. but unfortunately nothing happen.
    I've to load a new firmware, because I've an error: application platform.exe serious error window.

    coudl you help me?
    thanks
    David

    ReplyDelete
    Replies
    1. First you need to prepare your sd card with this:
      https://www.dropbox.com/s/ncr3vioawoslmnx/SDBOOT_wince.zip?dl=0
      Instructions are inside.
      then you can copy the fw on it and start the unit from gps slot

      Delete
  3. Hello KoTIK, thanks for your work,
    I want to know if the new audio player supports now Playlists, because that was the fact that make me change to Android, Wince audio player was very simple with no options. Thank you in Advance.

    ReplyDelete
  4. Ciao Kotix,
    ma come posso fare per applicare anche alla mia radio il tuo firmware utilizzando il tool di conversione, visto che sull'elenco C306 non è presente?
    Grazie
    Gianni

    ReplyDelete
    Replies
    1. Parli di android o di wince?

      Delete
    2. This comment has been removed by the author.

      Delete
    3. WINCE, VERSIONE ATTUALE FW 20130829

      Delete
    4. Mi dici quale mcu hai adesso? guarda nelle info.

      Delete
    5. Ok quindi... come mcu non c'è problema, il rsto lo devi impostare mnualmente visto che il setupdatexml.exe non lo puoi usare:
      Ti serve sapere che tipo di lcd monti (pollici e tipo)in modo da specificarlo nel file update.xml
      Puoi usare il mio skintool o cecmd per farti un backup dei files che ci sono nella cartella S100Program\
      in modo da usarli per crearti il tuo firmware, in particolare ti servono: ADSet.xml e MachineMapCanBus.xml ma se copi anche tutti gli altri è meglio (non la cartella s100UI).
      Poi vediamo se riesci ad andare avanti da lì....
      Ciauz :)

      Delete
    6. Nel file update.xml trovo solo l'impostazione dei pollici e non del modello (il mio 7" HannStar)
      Ho il bck, (S100Program-Backup) copio il tutto e sovrascrivo i file nel tuo nuovo fw? Corretto?
      Ciao

      Delete
    7. NO, non sovrascrivere tutto, solo il file adset.xml ed il MachineMapcanbus.xml
      Nel file update.xml metti LCD id="1"

      Delete
    8. Poi metti il tutto su una sd,
      Accendi la radio ed inserisci la sd da radio accesa
      Imposti il GPS path: \patch\UpgradePatch.exe
      Premi il pulsante navi e dovrebbe uscire patch ok.
      Riavvii la radio con la sd dentro e dovrebbe partire l'upgrade del fw.
      Non toccare nulla fino a che non tichiede ti togliere la sd.

      Delete
    9. Prima di fare l'aggiornamento ho voluto rimuove il tuo skin e dopo il ripristino non compaiono più le scritte.
      Ho provato anche a reinstallare lo skin3 ma sempre senza scritte.
      Posso comunque fare l'aggiornamento al nuovo fw ho mi devo preoccupare?
      Grazie

      Delete
    10. Può dipendere dalla modifica del file "string_Italian.xml" ?!?

      Delete
    11. Scritte ripristinate dal file originale "string_Italian.xml" e FW eseguito alla grande. Tutto OK.
      Un grande ringraziamento per tuo lavoro e per la tua disponibilità.
      Ciao

      Delete
  5. un ringraziamento per il tuo lavoro.

    ReplyDelete
  6. Hi KoTiX!
    I would like to try you great skin pack but,
    I need some help because I tried to update my chineese car radio firmware(C097) and it's not successful.
    During the fflash, I had a yellow screen with : "wince run..." reboot and now black screen.
    Please help me...
    Thanks

    models : http://www.autoradiogps-online.fr/in...l#product-tabs

    ReplyDelete
    Replies
    1. You probably need sdboot card now but I need to know exactly at which point of the flash the procedure has stopped.
      Feel free to contact me by email.

      Delete
  7. Hi Kotix. I have the same problem that Samidove. I tried to instal a new firmware. I had a yellow screen, and finaly put: wince run...
    but do not suces nothing. I wait 15 minutes and the same: wince run..
    Finaly i turn off the radio.
    Now, when i turn on the radio, only see a white screen whit vertical lines of diferent colours in the left of screen.
    If i put a complete firmware in a sd and turn on the radio, is the same. Turn on whit the same screen. I have two photos of the screens. If you nedd the fhotos, i will can send you.
    I ned your help, please.
    Thanks

    ReplyDelete
    Replies
    1. Did you set correctly the fw for your unit using SetUpdateXml.exe before flashing?

      Delete
    2. Have you the origianl fw for your unit?

      Delete
    3. Hi Kotix. No, i don´t change nothing before flashing, because i used a sofware for my unit (C 019) OPEL ASTRA H . The sofware it was of NAVISSON,( only chage de skin, i suposed). And now beguin my problems.

      I have the original fw send by chinesse seler. I put the fw in the sd, turn on, and the same yellow screeen.
      I thing that the sd gps unit, don`t recognize nothing.

      Delete

    4. So i guess you have flashed the c149 fw on your c019?? That's bad....
      Ok, in your original fw, edit the file update.xml and change from "true" to "false" the touchscreen calibration:
      TouchExe run="false"

      Then put the sd in gps slot, turn on the unit and wait 20 minutes. Remove the sd card and reboot. Even if you don't see nothing it will flash the unit.
      If it still don't wotk, you have to use the wince-sdboot procedure.

      Delete
    5. Hi Kotix, thank you for your answers.I tried the two metods you said me, whith diferent sd cards.
      -Wait 20 minutes
      -The wince-sdboot procedure

      And the same result. turn on, and ever the same sreen white whit colour lines verticals in the right side.

      something else: If i press source button and the same time press reset buttom, the unit reboot and only appears a full white screen.

      If you want, i whould like send you by email all the proces that i did, version sofware before the problem, the version who send the chinesse seler to me, and some photos of the escreens.


      I need help. please

      Delete
    6. Ok send them to me please.

      Delete
    7. Any success with this problem, guys?

      Delete
  8. Ciao Kotix,
    parli di aver risolto il problema della "Lista" con il nome della radio e non con la frequenza (orribile). Ho fatto l'aggiornamento delle skin, ma non è cambiato nulla!!
    Che devo fare??
    Grazie e complimenti per la competenza!!

    Mic

    ReplyDelete
    Replies
    1. Quella funzione la ottieni con l'aggiornamento del firmware, non con le mie skin.
      E' una funzione contenuta nel fw 1.6.9.
      Documentati su come si aggiornano i nuovi firmware prima di fare qualunque cosa.

      Delete
    2. This comment has been removed by the author.

      Delete
    3. http://kotixworld.blogspot.it/2014/11/s100-wince-firmware-flash-and-recovery.html

      Delete
    4. Scusa, ma non ho capito.
      La mia situazione attuale è questa: ho una S100 con ancora WinCE installato, non Android, con firmware C018 V 1.2.9.
      Dispondo del FW C018 V 1.2.9 trovato su roadnav.
      Per avere la Lista con i nomi delle radio mi basta usare SetUpdateXML_EN_2.exe selezionando la C018?
      Grazie ancora.

      Delete
    5. Dispongo anche del FW 1.6.9.18 però per la versione C149.
      Posso usare quello sulla versione C018?

      Delete
    6. Lo puoi usare ma prima lo devi convertire pe ril c018 usando il SetUpdateXml.exe
      Però controlla anche che il tuo c018 usi una mcu simile a quella del c149, cioè vai su roadnav.com e controlla che nei firmw abbiano le stesse mcu.

      Delete
  9. This comment has been removed by the author.

    ReplyDelete
  10. Kotix,

    In the case of I001, which would be the procedure to return to WINCE? Where can I find the files needed for the procedure?

    Tks

    ReplyDelete
    Replies
    1. http://kotixworld.blogspot.it/2014/11/s100-wince-firmware-flash-and-recovery.html

      Delete
  11. Hi Kotix, Thanks for your nice skins. They look much beter than original skin.
    How can i store by rds name? so far i can only store by frequency..

    ReplyDelete
    Replies
    1. you need the latest firmware 1.6.9

      Delete
    2. so firmware 1.6.9 is not included in your S100 skinpack 2014 ?
      where can i find this firmware?
      Thanks

      Delete
  12. Extract the skinpack on the root of SD card and put it in GPS slot, on the unit set Navi path to "\Skinmanager\Skinmanager.exe", press the Navi button

    Hi KoTiX is that a one off time or do i lose navi to have skins ?

    ReplyDelete
    Replies
    1. Read here:
      http://kotixworld.blogspot.it/2013/12/s100-platform-skinpack-31102013-its.html

      Delete
  13. Hi KoTiX.
    I am translate SkinManager to Russian language.
    https://yadi.sk/d/isBokHOpcZe4E
    Can i post in 4pna(com) and Cluborlando(ru)?

    ReplyDelete
  14. Hola: necesito ayuda para mi s100 c246, como puedo hacer un backup del firmware original? Quisiera modificar el logo... un saludo y gracias por la ayuda.

    ReplyDelete
    Replies
    1. No se puede, tiene que buscar el tu firmware en roadnav.com

      Delete
  15. Hi Kotix,
    I have installed your skin manger in to my S100 C109, first I installed skin 4, but I feel the digital clock too big, then I installed skin 3..it's going better, but I got some problem, everything is work, but bluetooth icon become media, navigation becam POP, and media became NAV and POP became BT, Do you have this case?
    Thanks

    ReplyDelete
  16. I welcome the DA Dalco Radio 765 on wines which MCU Version 6.0 DW-WinDD-140607A and want to change skurki Skinpack 2014 S100 whether it is in the radio do please help how to do it

    ReplyDelete
  17. I know you probably get asked all kinds of questions. and I hate to ask, But, can you help me out please?
    I have an S100 nav Radio (That's all I know), there is no manufacturer, no Brand, nothing on this radio. I bought from Radio-Upgrade for my 2014 Dodge Ram. I want to do the things to my radio as described here. here is the info from the Radio:
    OS Edition: S100-UNI.A20140721-A2.2
    APP Edition:S100-V1.6.9.0
    MCU Edition: Z0NM S00E C286
    DVD Edition: 3255 V100 7706
    BT Edition: 20121204
    CAN BUS: Connect Success
    OEM Info: A002


    Can I upgrade it to the S150? If so, How? or can I change it up like you show on here with new skins? If so, How?

    Please let me know, and thank you for your time.

    ReplyDelete
    Replies
    1. Your model is c286, so if exist the android firmware for i286 you can convert it to android.

      Delete
  18. ciao kotix,
    mi piace molto l'aspetto della tua skin!
    Ho però un modello credo particolare di fw relativo alla bmw x1 ossia il c219 che comprende anche l'idrive (telecomando da plancia)
    E' possibile per il mio modello installare il tuo firmware oppure anche solo le skin per migliorare la visualizzazione di testi ecc senza perdere l'idrive? attualmente ho installato l'ultimo fw originale wince preso dalla roadnav/forum.
    aspetto novità,
    grazie ed ottimo lavoro!

    ReplyDelete
    Replies
    1. Prova a mettere la skin , al massimo rimetti l'originale con skinmanager lanciandolo col tasto navi.

      Delete
    2. cioè senza flashare, inserisco nello slot gps una sd con solo la cartella skinmanager e le altre cartelle skin 2,3,4 poi metto nel gps path skinmanager.exe e basta?

      Delete
    3. Una SD con tutto lo skin pack estratto dentro.
      Se non ti fidi,attendi qualche giorno che sul sito roadnavdotcom troverai anche il tuo Fw.

      Delete
    4. Più che altro non confido molto sul fatto che rilascino aggiornamento per il c219 visto che quando chiedo news non mi rispondono mai in nessun post e la versione Android i219 infatti è l'unica che non hanno aggiornato. A quel punto mi affiderò a te commissionandoti un custom work dietro pagamento ovviamente se possibile.

      Delete
  19. Hello Kotix,
    I installed your skin, fantastic, but I have a little problem with the buttons.
    I press navigator and part of the music player, I press the bluetooth and part of the navigation, and so on.
    Practically there is no match between buttons and functions.
    Mine is a C207 S100, you may solve?

    ReplyDelete
    Replies
    1. same issue for me with C207, may we have to edit a config file somewhere? Thanks

      Delete
    2. You need firmware vers 1.6.9 or 1.7.9

      Delete
    3. my C207 is 1.6.9
      can be resolved in some manner?

      Delete
    4. Yes, it will fix it.
      For 1.6.9 firmware use the 26/10 skinpack , not the newest 15/11.

      Delete
  20. Hello Kotix, I just do Roadnav update:

    OS: S100-UNI.A20140721-A2.2
    APP: S100-V1.7.9.0
    MCU: P00N S00E

    So far everything is working ok
    The last skinpack works for this version?
    I wonder how do I change the language to Portuguese?
    Thank you!

    ReplyDelete
    Replies
    1. It work but nave problem with music search. I'll release a new version this weekend forma 1.7.9

      Delete
    2. Portuguese is in settings->general

      Delete
  21. Hi Kotix,

    I'm so glad to ear that you're back on S100 development !! I'm using your skinpack (skin 4) for few month now, and it's just perfect !!

    I will follow your work for this platform, and maybe new skins in the future ?

    ReplyDelete
    Replies
    1. I'm glad you like it.
      Please consider donating :)

      Delete
  22. Ciao kotix
    Sono denisds del forum Kia
    Ho una C097(Mazda cx7) passata a C201
    Ho installato 1.6.9 e la tua skins
    I comandi al volante mandano avanti e indietro 2 canzoni invece di una
    La radio non funziona la ricerca delle stazioni tramite comandi al volante o rotella
    Cambia solo le stazioni memorizzate
    Io abito in un brutto posto e continuo ad andare in cerca di una canzone che mi piace
    E quindi sono sempre in ricerca
    Sai come risolvere?
    Grazie mille

    ReplyDelete
    Replies
    1. La ricerca stazioni avviene tenendo premuto next o prec sui comandi al volante.

      Delete
  23. Hello Kotix,
    File: string_Portuguese.xml this in the firmware folder, put in settings-> general does not have the option of Portuguese. How do I make it work in Portuguese?
    Thank you!

    ReplyDelete
    Replies
    1. ok, probably you have to flash a slightly different firmware version like 1.6.9.xx
      Where xx can be "0", "13", "18" depending on your language, i just don't know which is it, maybe the "0"

      Delete
    2. Ok Kotix, the version with the "18" at the end is the one that works in Portuguese. New updates, just found the version 1.6.9.18 with the same MCU my unit. Can I install the new skinpack (1.7.9) or previous?
      Thank you!

      ps: translated from Portuguese by Google

      Delete
    3. With 1.6.9.18 work the skinpack in this page, the new 15/11 skinpack is for 1.7.

      Delete
  24. Hi KoTiX,

    First I'd like to thank you for your struggling, testing and sharing info & updates on these gadgets ;)

    Secondly, I'd like to ask you about the HW issues that you are atlking about on using 4.0.3. Is this applied only to S100 models or it's valid as well for S150 models which originally came equiped with 2.3.4 ?

    I have i019 (Opel Astra H....) model which I've upgraded to 4.0.3 for some months on my supplier (I assume it's an original version upgrade for it).

    I'm having some bothering issues with it:

    1. cannot connect to any WiFi networks anymore....it's in a continuous loop of connecting, obtaining IP, and so on
    2. bluetooth / phone app has more issues:
    a. hardly could download completely phonebook & call log, waskeeping gettin' stuck at some point, and had to start over;
    b. it contains some 4.0.3 bug (ofcourse) regarding recognizing incoming caller IDs (something about international code & phonebook), so I never know who is calling me
    c. the call logs are not gettin' updated automatically with calls placed trough the system (like the old one did)
    d. searching trough contacts, it's a pain in the ass: cannot see full name per each line until you place the call & starting to type a phone number doesn't filter my contacts to choose one....
    3. music app, all of a sudden, has no sound at all (playing from SD card), which was working ok some time after update

    I have received today a newer version from my supplier, which I'll give it a try myself (I hope I'll manage to install it succesfully & work better).

    In case not, I will revert back to 2.3.4, although I don't have an original, tested, stable FW kit, do you have one ?

    Finall question, is about MCU. What does it mean, and does it need to be the same between Android version ?
    I see that on my original 2.3.4 this was A003, now I have M004 and the new update has O005.

    Thank you !

    ReplyDelete
  25. The overheating issue has happened to me on s100 and on s150(2.34) boards, both of them were running android 4.03 but s100 died the lcd controller i guess, the s150 was having no sound on android ones in a while.
    I converted my s150 to S100 (wince) and i have no sound issues anymore.
    So in your 3° point you have definetively lost audio from the cpu board and you need to try to resolder it or reflow it.
    To be sure it's not a hardware failure you should flash android 2.34 and wince too.
    All the 2.34 firmwares are the same, just replace the config folder with your original one and the mcu you had.
    Good luck ;)

    ReplyDelete
  26. Hm, bad news have you me for ... Obi Wan.

    I can put windows on mine and work ?
    All apps, drivers, SWC, etc ?

    How can I do that ? Which firmware / settings shall I try ?

    Thx !

    ReplyDelete
    Replies
    1. you need to prepare the sdcard with sdboot and the firmware for the equivalent model to i019 that is c019.
      but first try your original 2.34 fw

      Delete
    2. That's the ideea, I don't have the original 2.3.4 fw.
      I only got one sent by carnavyplayer....which I hope will do the job....

      Do you where can I find another one just in case this one will fail ?

      but first, tomorrow morning, I will give a try to the newest 4.0.3 version that I got today

      thx

      Delete
    3. http://yadi.sk/d/x0vCrMpLF7Djx
      Edit the files in the config folder to match your unit specs, take them from the 4.03 fw.
      Use an mcu file that you know is ok for you, here some old mcu files: https://www.dropbox.com/sh/ousyh4yv3kl030k/AAD8bNINHrjfpiX79qWIfiBAa?dl=0

      Delete
    4. I'll give them a try.

      I had on mine A003 as MCU version, but on the only complete kit I have there's E003 which I've found on your Dropbox link as well. Maybe it's the latest version for 2.3.4

      I'd be happy to have it working fully on 2.3.4 like it was before.
      I'll keep you posted.

      Thx !

      Delete
  27. Today I've flashed the latest 4.0.3 that I've received yesterday, but didn't had enough time to test it.

    Music player has sound, for now....rebooted once, still ok
    I could connect to WiFi once

    I'll give it some more time to test (but not that much) and maybe go back to 2.3.4.

    It's really interested to test (or even maybe stick on) the WinCE version, but I see there were some guys with some issues that need to replace their boards (not so pleasant).
    This happened only because they've flashed a wrong version or nobody knows why this can happen ?

    Yesterday I could download my v1.7.9 for C019 (I have S150 I019), but it's strange that now I cannot access at all roadnavs' website....glad that I got it though....

    I'll keep you posted if I'll have the courage to try WinCE ;)

    Thx,

    ReplyDelete
  28. Ahhhh, for 2.3.4 do I need to fuse another uboot file ?
    Just tried with the one used for 4.0.3 but with 2.3.4 fw and the screen is still black after 10 minutes....

    :(

    ReplyDelete
    Replies
    1. Yes you need another dootloader for 2.34.
      Some guys who flashaed back wince have flashed a wrong version, some other don't know what was wrong.
      I beleive you are safe enought if you flash the original c019 fw but , you know, shit can always happen...

      Delete
  29. Ok, I already found it on the internet, and already flashed with the 2.3.4 version that I got from carnavy.
    But again, NO SOUND on Music player :(

    Everything else works great, including WiFi or Phone app.

    Could this be due to MCU version ?

    Originally when I bought the device, it came with A003 version.
    On this latest 2.34 kit there's E003 installed on it.

    On latest 4.03 I got O005 where as well, sound was working (since last night when I flashed it)

    Is there a connection between MCU versions and major Android versions ?
    Thinking to re-flash 2.34 using MCU version from latest 4.03 for my player, is it a good idea ?

    I don't see A003 on your MCU list....

    This is also connected with Wireless functionality ?

    I would have preferred to stick on a stable / fully working v2.34, but it seems I'm not lucky, thus being forced to try WinCE....

    ReplyDelete
  30. ciao kotix
    ho installato le tue skin ma i pulsanti non corrispondono piu': nello specifico il tasto media e' diventato navigatore, il bluetooh e' diventato il tasto media etc... Questo anche dopo il ripristino della skin originale. Mi puoi aiutare?

    ReplyDelete
  31. ok Kotix, ma prima di aggiornare il FW devo disinstallare le skin?

    ReplyDelete
    Replies
    1. Quando aggiorni il Fw le skin si cancellano. Le dovrai rimettere.

      Delete
    2. grazie, il fw dove lo trovo? l'autoradio cinese e' un a s100, la versione app e' s100-v1.0.9.0, la versione mcu f00k s00b c155 oem info a002, montata su una chevrolet orlando,
      crazie mille

      Delete
    3. Ciao KoTix sul sito non trovo traccia dell'aggiornamento x la mia versione c155.
      Non e' stato rilasciato?
      Posso usarne un'altro?
      Grazie anticipato

      Delete
  32. Hello again Kotix,

    I finally convinced myself to give a try to Windows CE before sending the unit for RMA, as with Android I have lots of issues....
    I've prepared the card using your steps above (SDBOOT), and gave it a try (actually more tries) this afternoon.

    Pulled out all the cards, CD and disconnected BT devices.
    When I boot with the card in the GPS slot, the screen is blank (black) and think nothing happens.
    I've waited 20 minutes and nothing. I've pulled out the card, nothing.

    I've rebooted (using ACC turning off the ignition), and it didn't boot on Android as well.
    Fortunatelly, reinstalling Android 4.0.3 made it alive again.

    What have I done wrong ?

    I've used the SDBOOT loader from the zip arhive as indicated and seen in the screenshots, but I see I have a boot.nb0 file in the image folder of the firmware, which is actually same size as the one in SDBOOT archive. I will give it a try.

    Now, reading the comments (again), I remembered that might need to put Android 2.3.4 first, and give it a try again.
    Is this the case ? Any other thoughts ?

    Thanks !

    ReplyDelete
    Replies
    1. another thing. I couldn't fuse SDBOOT loader on Windows 8.1 or 7 (both x64).
      I get: Can't read MBR sector from Drive !

      Is the 64-bit OS the issue ? Do you know something ?
      Here, at home I don't have (anymore) any x86 OS (Windows), so I'll wait for next week @work or install a virtual machine

      Thx,

      Delete
    2. Use nb0 from sdboot package only, run sdboot as administrator

      Delete
  33. That's rockin. It's great you are keeping this platform viable... I'm gonna paypal ya a little something next paycheck. My S100 has been pretty flaky - just running on WinCE. Now I have gotten in the habit of shutting it down before turning the car off. Seems when I let it power on when the car was first started it would hang a lot. Maybe voltage regulation issue, i dunno.

    Would be awesome to be able to reliably run Android 4.0 though - for just this reason: https://www.automatic.com/ Bluetooth OBDC interface - wooo!

    ReplyDelete
    Replies
    1. My unit has the same slow booting problem and i beleive it's just some bad capacitors on the mainboard bit i'm too lazy to try to fix it... It's not that slow right now.
      Forget bluetooth obd, maybe a WiFi one.
      Ciao. :)

      Delete
  34. Ayuda mi s100 con sofrware original no se escucha ni audio ni video tampoco el gps, solo el dvd, tv y radio, ayudaaa

    ReplyDelete
  35. I am using an S100 CAR DVD system in my Opel Astra model C019. It plays FM, DVD, bluetooth and VCDC well, but when I play music from USB, MICROSD CARD and HARDDRIVE, I hear only hissing sound like an FM station out of tune. I have resetted and upgraded the system thinking it will solve the problem, but the problem is still there, Is there a way you can assist me with this?

    ReplyDelete
  36. I hear of resoldering or reflowing. How do I do that?

    ReplyDelete
  37. I got the C088 for my Citroen C4, I installed and all is fine except for the Hebrew fonts that are missing, as results the contacts names and the address in the igo gps appears as blank squares.

    I would like to add Hebrew fonts to the units just for the gps and the contacts names, can you help me please and direct me how to change the default fonts to be Hebrew type, thanks

    ReplyDelete
  38. hello I kotix, I have a s150 system Android 2.3 I would like to convert it to wince, give me instructions how to do, I want to download the skin,

    thanks Orazio

    ReplyDelete
    Replies
    1. Please send me an email, Check my profile on the right side of my blog.

      Delete
  39. Ciao Kotix io ho un s150 android 4.03 (il tuo fw mod in breve). Posso convertire a winCE o la procedura funziona solo per s100?
    Grazie

    ReplyDelete
    Replies
    1. Se hai una mia ROM fino alla 2.6 puoi usare sdboot tranquillamente. Se hai la 2.7 devi prima tornare alla 2.6.

      Ciao.

      Delete
  40. Que tal amigo, que necesitaria para actualizar mi s100 c044 a android?

    ReplyDelete
    Replies
    1. Contactame por e-mail porfavor.
      Gracias.

      Delete
  41. How do you change the logo screen from the dodge logo to the ram logo?

    ReplyDelete
  42. How do you install the ram logo so it can be changed?

    ReplyDelete